Honda Prelude Forum banner
21 - 27 of 27 Posts

·
Registered
Joined
·
4 Posts
So, I have same issue. 1998 Base model with H23 engine swap. Car just shuts off randomly while driving.

I just got back from picking my car up at the stealership. Had the Ignition recall done. New distributor. New NGK plugs. New cam plug, head gasket, and other probably unrelated gasket/seal fixes.

Based on forum posts, I though for sure that the Ignition recall would fix the issue.

Negative. Same issue, only worse. It happens more often and the car doesn’t want to start in neutral while I’m coasting.

If I coast a block or two, it will restart with lots of throttle applied. But, it will only run for a block and then instantly die.

Took it to another mechanic to diagnose.

Will try to replace main relay, since that’s been posted a lot.

Frustrating as hell!
 

·
Registered
Joined
·
591 Posts
After you check the Main Relay...

Does it sputter and die or is it off and on like a light switch?

I had a fuel pump that just sort of died but it seemed heat related. Long drives, it'd sputter. Park it for a bit and it'd work better again then degrade. Essentially it was a fuel pressure issue. I swapped the pump and has been fine since.
 

·
Registered
Joined
·
4 Posts
No sputtering. Running fine one second, then engine instantly cuts out as if I turned the key off.

I’m replacing the Main Relay and the Ignition Coil today.

My main relay didn’t show any signs of cracked solder. But, it has several smaller relays on it that might have crapped the bed. So,just swapping that out with OEM one just to be sure.

I’ll post with the results of a drive after pick it up this afternoon.
 

·
Registered
Joined
·
4 Posts
OK, picked up the car. Drove on the highway. Perfect. Drove up and down a small mountain road. No problem. Took it through town and back home. Ran fine.

Total fix: New distributor. New Main relay. New ignition coil. New NKG spark plugs. Did Ignition recall at Honda dealer.
 

·
Registered
Joined
·
4 Posts
So, it’s been 6 months and the car has not died once after all the fixes that I posted above. Then, it died 4 times today identically to how it was dying before. Any suggestions that I haven’t already tried?
 
21 - 27 of 27 Posts
Top