Honda Prelude Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
Short version:
My car stalls when my RPM's drop. Not everytime but a lot. In addition it is only when the car is warm. The car will shutterwhen coming to a stop and sometimes, as i am slowing with the clutch in, the car will die as well.
Long version:
I had a CEL that was pointing to the cat. I picked up a magnaflow direct bolt on cat and had it installed by meineke. I picked the car up and a .25 mile up the road got a new cel. The first o2 sensor. In addition it was riding like crap. when i came to a stop, theRPM's would comedown to the point that the engine would shutter and then recover. It got worse as the car warmed up andbegan to stall. I replaced it and am still having the same issue.
What could be wrong? Could it be the cat???? The issues started when i picked it up after having it installed. The only performance part i have is an AEM cold air intake.
 

·
Registered
Joined
·
4,614 Posts
Your o2 sensor may need to be replaced. The one on your cat. I had to have mine replaced recently. And i only have 70k miles. Don't you love cars.
 

·
Registered
Joined
·
1,870 Posts
Have you tried resetting the system? Taking the (-) off the battery for a minute or two then connecting it would give the cars computer system to "Re-learn" the new changes in the system. Just like changing your hand out with a hook without telling you, and expecting you to become an artist right then and there.
 

·
Registered
Joined
·
85 Posts
i had that problem with my car. check to see if both your condensor fans are working. i would have the a/c on and when i was in stop and go traffic the car would choke. got a new fan and no more stalling.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #5
Your o2 sensor may need to be replaced. The one on your cat. I had to have mine replaced recently. And i only have 70k miles. Don't you love cars.
Does this sensor affect the fuel mapping or idle?
What are the symptoms of the secondary O2 failing? I have only driven 6 miles since the battery was replaced but it was a miserable 6 miles when your car turns off too often. I just dont know that it is enough time for the secondary O2 to throw a CEL or not.

My understanding was that it just read the post cat mixture and made sure the cat was functional. It is due to be changed (160k miles - okay overdue :) ) but I have spent a fair amount recently between the car and christmas and dont want to just do general maintanance right now.

If you feel that could be the issue, i will gladly change it though. Any other ideas?
 

·
Registered
Joined
·
10 Posts
Discussion Starter #6
Have you tried resetting the system? Taking the (-) off the battery for a minute or two then connecting it would give the cars computer system to "Re-learn" the new changes in the system. Just like changing your hand out with a hook without telling you, and expecting you to become an artist right then and there.
The battery died at the end of all of this and was replaced. In short, yes but it was only 6 miles ago. I would expect the car to run correctly in that 6 miles if that were the case. correct?
 

·
Registered
Joined
·
10 Posts
Discussion Starter #7
i had that problem with my car. check to see if both your condensor fans are working. i would have the a/c on and when i was in stop and go traffic the car would choke. got a new fan and no more stalling.
I will take a look at that. This is stalling more often then stop and go unortunately. I was coming to a light at 40 or so and because i held the clutch in, the RPM's dropped down and the car turned off. I had to coast into a parking lot. It turns right back on, but if i rev it to about 3 or 4 in nuetral and let it come back down, it may turn off again.

I am pretty sure that the AC was off though as i wanted to hear the car since i changed the primary O2 and the battery. I had the radio off for SURE, and i am pretty sure that i turned off the ac as well. I will check though.
 

·
Registered
Joined
·
16 Posts
i had a problem similar to dis. thought it was my timing but come to find out as i was taking the belts off the seal holding the a/c and powersteering on the underdrive pulley wore out and would wobble. My car would stall out while driving on the highway and when i would slow down from time to time. I Checked timing and ordered a new pulley from honda. Dat's jus my experience you might hav another problem. A friend from honda also told me the recall sometimes had to be done twice. So check the recall.
 

·
Registered
Joined
·
218 Posts
my brother has the same problem. we're following the write up on cleanin ur egr valve (cant do ports yet), iacv and fpr. we're gonna go ahead and do a major maintance hopefully within the next couple weeks including cleanin the injectors and so on and so forth. did you ever get ur car straightened out?
 
1 - 13 of 13 Posts
Top