Honda Prelude Forum banner
1 - 3 of 3 Posts

·
Read Only
Joined
·
4 Posts
Discussion Starter · #1 · (Edited)
Hey everyone

So I was driving my 1991 (JDM) Prelude home from a weekend away and when I hit the motorway my dash went a bit crazy. The speedo dropped to zero, the sports light started flashing and the check engine light came on. The cruise control may have also disengaged but I'm not 100% sure.

I took the first exit off the road and turned my car off. upon turning it back on everything seemed fine until a few minutes down the road when it did it again, same issues (excluding the check engine light, which hasn't come back on, yet).

I took the next exit again and stopped. After a quick call with a friend of a friend who was a mechanic I was told my car would make it home as long as the engine had no performance issues (which it did not).

Throughout the entire drive (around seven hours) the car seemed to run fine with none of these issues resurfacing, except possibly the cruise control disengaging (again, not 100% sure).

My questions are: does anyone know what might have caused this? I have checked the fuses in the engine and they seem to be in working order. Is there anything else I should check? Should I take my car into an auto-electrician or ignore the problem until it comes back?

Thanks for any help you can give,
Caleb

P.S My car cut out when I put it into reverse after initially getting in but didn't do it again. As my car is automatic I thought that this could be a fuse/electrical issue.

EDIT: My car won't start now. Just tried to go to university and it turns over but doesn't fire. Power to the spark plugs maybe?
 

·
Read Only
Joined
·
4 Posts
Discussion Starter · #3 · (Edited)
I would run normal diagnose. Might be something to do with your ignition switch from how I read that.

Sent from my SCH-I535 using Tapatalk 2
Thanks for the reply.

My beloved car has been picked up by a tow truck and is on the way to an auto-electrician. I'll let you know when I know what the issue is. Hopefully it's not too expensive...

EDIT: Fuel pump. It turned out the fuel pump has completely died. It's going to cost around $700 NZD to get a new one from out of town installed. That price covers towing cost, parts and labour apparently. I'll edit again once the work is complete to give a final cost.
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top