Honda Prelude Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
Hello. This is my situation. I bought a 1997 5th gen prelude 5 speed for 1500. Pick and pull. The problem is code. P1660. How can I fix this. ?
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #4 ·
I checked the manual and what I found was weird. It says that p1660 is a code for automatic trannys. But I have a 5 speed .
Maybe is the ecu swap for an automatic ?
 

·
Administrator
Joined
·
6,802 Posts
I checked the manual and what I found was weird. It says that p1660 is a code for automatic trannys. But I have a 5 speed .
Maybe is the ecu swap for an automatic ?
Possible. Take a look at your clutch pedal mounting as well as cluster and firewall. Doesn't hurt to run the vin at Honda or carfax and see what it comes up with
 

·
Registered
Joined
·
675 Posts
I checked the manual and what I found was weird. It says that p1660 is a code for automatic trannys. But I have a 5 speed .
Maybe is the ecu swap for an automatic ?

Glad you looked. You are learning. Do you have a check engine light on or did you just plug in a code reader and it said that was the problem? Is there a real issue?


PS i had stepped in cow patties before i stepped on your pie.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #7 ·
Okay I found the problem ... My ecu is from an integra ls. The number on the ecu is 37820-p75-a52. Then I check the engine block and it is an h22a4. I also did a car fax report and it is a 5 speed.

So all I have to do is find an ecu ..right ?
 

·
Registered
Joined
·
58 Posts
Okay I found the problem ... My ecu is from an integra ls. The number on the ecu is 37820-p75-a52. Then I check the engine block and it is an h22a4. I also did a car fax report and it is a 5 speed.

So all I have to do is find an ecu ..right ?
Well that is interesting for sure.

The proper ECU would be a good place to start.
 

·
Registered
Joined
·
675 Posts
Okay I found the problem ... My ecu is from an integra ls. The number on the ecu is 37820-p75-a52. Then I check the engine block and it is an h22a4. I also did a car fax report and it is a 5 speed.

So all I have to do is find an ecu ..right ?
Oh man. That is a big issue. Did it even run?
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #12 ·
Yes the prelude is running fine no problems. it's just that I can't remove the check engine light .

So I bought a new ecu. P5m l05 and I swap the ecu the car didn't turn on. All the lights turn on. But it just won't start. So now I have to take it to the honda dealer to get a new red key and immobilizer.

Is their any other way I could fix this issue ? With out going to the dealership?
 

·
Registered
Joined
·
273 Posts
there's a lengthy discussion about it on this forum. short answer is not easily or for free. you're key, immobilizer and ecu all need to be programmed together.
 
1 - 14 of 14 Posts
Top