Honda Prelude Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
My mechanic and I are stunned and running out of options.
Misfire started after motor swap, everything around motor is the same as before with no misifre.

Cylinder 1-2-3 most of the time, sometimes 4th also.
Misfire tends to appear minutes after start, when cold. Runs alright tho, some little hesitations but not much.
When warm, runs like new...

What is done/checked so far:

-Spark plugs
-Wires
-Distributor, cap, rotor
-EGR valve
-EGR ports cleaned
-Fuel injectors
-Fuel pump
-IACV
-Coolant bleeded
-Engine coolant temperature sensor
-Dry compression test (180 all around)
-Vacuum leaks

Thanks for helping, what to get rid of that headache.
 

·
Administrator
Joined
·
6,799 Posts
By motor swapped, what do you mean? Stock for stock motor or a conversion?
 

·
Registered
Joined
·
7 Posts
Discussion Starter #6 (Edited)
Thanks for your answer guys.

MAP, IAT should be eliminated since we tried an whole other intake manifold (with sensors and all) and misfire still occurs.

Dry only, not wet compression test was done, 180 all around.

What are the odds the cat is shit right away after motor swap. I count this out.

Will do fuel filter but again what are the odds it's shit suddenly after swap.

Will check grounds, this is swap related so it is possible. Would bad or missing ground cause misfires??
 

·
Opinionated Bastard
Joined
·
7,272 Posts
Another thing popped in my mind- how well is the intake manifold sealed up? If you didn't scrape all of the old gasket off and it isn't sealing well, it's possible that you've got a vacuum leak that's causing a lean condition and knock. Not terribly likely, but possible.

Timing check out okay?

Where did you get the current motor from, and is it a completely stock long block that's never been apart?
 

·
Registered
Joined
·
7 Posts
Discussion Starter #8
Old intake and new intake with new gasket... misfire with both so I would eliminate that.

Timing OK.

Like any old motor, I have no clue where it is from and what was done to it.
 

·
Opinionated Bastard
Joined
·
7,272 Posts
I would probably lean toward something internal with the motor, then. You did a compression test, what about a leakdown test? Maybe bent valves in the head, which would cause it to seal 'ok' during a compression check.

Also, how did you guys do the compression check when it was dry?
 

·
Registered
Joined
·
1 Posts
I have this exact same issue, same swap as yours. Did a valve adjustment and haven't had a problem since. When mine was doing it, I was getting a check engine light, a PO300, 301, 302, and 303.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #13 (Edited)
What are the odds all 4 cylinders valves are bent?

I dont know too much about compression test but he was plugging the machine in each cylinder and i would crank 3 sec with the key inside.

Added a ground on the head near alternator.
Changed ingnition coil.
Changed pcv valve.
Did idle valve check.
Redid compression test.

Still..........

Next step, adjust valves, check for rounded cam lobes and change crank sensor.
 

·
Registered
Joined
·
1 Posts
I was getting p0300 (random misfire), p0301-p0304 and my CEL kept blinking. Adjusted valve clearances to spec, cleaned out the EGR ports from the intake manifold, cleaned EGR valve and changed all intake gaskets. CEL didn't come back on and car runs smoother.
 

·
Opinionated Bastard
Joined
·
7,272 Posts
What are the odds all 4 cylinders valves are bent?

I dont know too much about compression test but he was plugging the machine in each cylinder and i would crank 3 sec with the key inside.

Added a ground on the head near alternator.
Changed ingnition coil.
Changed pcv valve.
Did idle valve check.
Redid compression test.

Still..........

Next step, adjust valves, check for rounded cam lobes and change crank sensor.
The odds are pretty good, especially if the timing belt ever snapped on this motor and the seller "forgot" to tell you.

I would say adjust the valves next and check out the valvetrain. Hopefull your didn't buy a boat anchor for a motor.
 
1 - 16 of 16 Posts
Top