Honda Prelude Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I rebuilt the motor in my car put a sleeved block with high compression Pistons eagle rods aftermarket fuel pressure regulator 500cc injectors I had the block port and polished along with the cylinder head I had the crankshaft balanced and leveled whatever that means and a few other things I'm sure but my problem is I'm not getting gas to spit out of those 500 CC injectors I had to buy connectors to hook on to each injector to even be able to hook up to my engine harness but the fuel rail is AEM and a fuel pressure regulator is from eBay but I'm not getting any gas either way to the injector the fuel rail is getting gas because I seen it
 

·
Registered
Joined
·
3 Posts
Discussion Starter #2
Whenever I pull each injector out gas spills out of each one so they're getting gas all the way to each injector it's just not spraying out
 

·
Registered
Joined
·
14 Posts
Hmm, I'm not the most experienced fellow on this forum, but I will give my thoughts to try and help you out.

Getting gas to the injector, nice. No spray. The problem must lie in either the fuel rail not being pressurized properly or the injector not getting power in order for it to fire.

Check that the injectors are getting power, then check the fuel system pressure, also making sure to check that the fuel pump is priming when ignition is switched on. Then, make sure your ECU/Tuning Software is correctly controlling the fuel injectors.

You mentioned you had to change the connector on your engine harness for the new injectors. Try checking you wired the connectors properly, power to power, ground to ground, etc.

If nothing works, maybe check what's going on with that ebay fuel pressure regulator? Make sure its functioning correctly and not any part of the problem.

Best of luck bro!
 

·
Administrator
Joined
·
6,589 Posts
Did you get the proper injectors for your vehicle? Saturated or Peak and Hold

Are you running a management system that supports the injector upgrade?

Do you have an injector pulse signal?

Did you adjust fuel pressure for the new injectors?
 
1 - 4 of 4 Posts
Top