Honda Prelude Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
120 Posts
Discussion Starter #1
ok i figured my iac was either dirty or needed replacing so i cleaned it the first time and that was a no go so i replaced it and i still have the same problem it revs up and down to as high as 3k w/out me touching the gas so if anyone has any idea what i should look for or replace ur opinion would be great...thnx
 

·
Registered
Joined
·
1,712 Posts
vac lines. also check to see if you are leaking at your TB or IM. also check the FITV valve under the TB. pull it off, clean it and tighten the valve back in there!. mine way hella loose and made a great improvement. check to make sure your MAP sensor is connected right too.
 

·
Registered
Joined
·
488 Posts
your not suppose to clean all those parts you guys just listed...check for vacuum leaks and if nothing comes up, check to see if your IACV works.
 

·
Registered
Joined
·
2,745 Posts
Check your coolant level. The iac vavle uses coolant temp to tell when to stop giving gas and go into a closed loop. check the level in the tank and the radiator. if the tank has more than the radiator the replace the cap. If neither have any then you have a leak.
 

·
Registered
Joined
·
956 Posts
I googled IACV cleaning and I finally got around to cleaning it and so far it helped!!! Bc my idle was bouncing randomly up to 3K. Mine wasnt as dirty but that was wha the prob was and that also my coolant was more black then green!!! :rofl: So I had that flushed out and filled in with new ones!!! :top:

Here...not sure if this helps anyone?!?!
Reps are cool if it did!!! :kungfu:

http://www.superhonda.com/forum/f94/diy-cleaning-your-iacv-144463/
 
1 - 6 of 6 Posts
Top