Honda Prelude Forum banner
1 - 7 of 7 Posts

·
Premium Member
Joined
·
4,656 Posts
the original may have been stuck open thus not allowing your car to heat up. but you could have had more than one problem, if you properly bled the system of air and the fans are not running, your rad fan switch could be bad or your fan motor could be bad. if you set your heater controls to defrost and press your a/c button, turn the blower in car on too, your condensor fan should come on. this could assist you while you diagnose the problem without overheating the car. leave the selectror in the heat side.
 

·
Registered
Joined
·
758 Posts
Check your fuses and your relay there is a fuse in the underhood fuse box ( the relay is also there) and there is a fuse in the drivers side fuse box
 

·
Registered
Joined
·
9,584 Posts
okay, so i bleed the system and changed the temp. sending unit. now the needle does not go up as high as it used to when it reads hot. stays between 3/4 of the way up or just about to the red. so what else can i check?
Posted via Mobile
The temp needle should be right at the middle 100% of the time. Erm, except when it's still warming up.

Does it read 3/4's when you're cruising, or just when the car idles?

Check coolant level. This is done by removing the radiator cap when the engine is completely cool. Look in the radiator for fluid. If you don't see any, the fluid is low. Top it off with 50/50 mix. (50% distilled water and 50% antifreeze).

Double check the fan wiring. Make sure the sensor is screwed in and the wire connection is plugged in.
 
1 - 7 of 7 Posts
Top