Honda Prelude Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
so when i hit 5.5k rpms my car blocks off as if i were redlining

i thought i would need a bigger fuel pump but i found out that its the same or something

any help?
 

·
Registered
Joined
·
1,350 Posts
check engine light, cloged injectors , cloged fuel pump or rail or fuel filter, any noise ? help me out so we can help u out post a vid thanks
 

·
Registered
Joined
·
1,277 Posts
yeah its hard to tell you what it could be from that info... theres a lot it could be... do you have aftermarket stuff on it... is it stock... all kinda of stuff we need to know for that
 

·
Registered
Joined
·
175 Posts
so when i hit 5.5k rpms my car blocks off as if i were redlining

i thought i would need a bigger fuel pump but i found out that its the same or something

any help?
Need more input, is your check engine light on. We don't even know what engine you have in there. This diagnosis stuff is like algebra, we do need part of the equation to find the missing variable or else you are just going to get too many answers.
 

·
Registered
Joined
·
1,277 Posts
it says h22a vtec bogging down in his title... so id think he has an h22a but not totally sure... maybe i just cant read lol jp yall but that is really in his title
 

·
Registered
Joined
·
175 Posts
lol, I see that now.
 

·
Registered
Joined
·
1,350 Posts
man i had some guy the other day come in a 4th gen lude thinking they all had h22's and he had a non vtec f22 engine
 

·
Registered
Joined
·
3 Posts
Discussion Starter #10
lol sorry i wrote that late at night

no check engine light

its stock pretty much just after market exhaust, header, intake

i still have the old tach from my h23 and it seems to block off at the old red line but thats probably just a coincidence..

not really any noise except loud noise from the exhaust

thanks for the help i could use any input

i might just have a mechanic look at it

it sounds like my vtec kicks in but the engine blocks off so i dont really have time to listen
 

·
Registered
Joined
·
175 Posts
Is it a recent swap? I dont know for sure what the redline is on the H23 or F22 or whatever your car came with, but maybe it has the old engines ECU still. Are you sure you are hitting VTEC? Cause Vtec kicks in at about where you are "redlining" or cutting off.
 

·
Registered
Joined
·
1,277 Posts
check your spark plugs, plug wires, injectors, all your fuel crap and after that make sure you have the right ecu to run the h22 and not an h23.. the h23 redlines at 6500 rpm but your sayin to bogs about 5500 which is where stock vtec kicks in but then again... it shouldnt kick if you dont have the right ecu i dont think... but if the car is good up to 5500 rpm then drive it normal till you find the problem to get her fixed up right
 

·
Registered
Joined
·
3 Posts
Discussion Starter #14
i have the h22 ecu in that the motor came with

i think ill change the oil on friday and get new plugs and wires and see if that does anything

the injectors are the ones that the motor came with (with extensive cleaning -___-;)

and i tried revving as high as i could and it blocks off at 6k rpms

lol the other numbers were just me glancing but i was paying attention this time

thanks for all the help :)

appreciate it greatly
 
1 - 14 of 14 Posts
Top