Honda Prelude Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
29 Posts
Discussion Starter · #1 ·
Hey all, looking for some advice about my exhaust. Took a quick look underneath and most of the piping is rusted out and it is split near the rear passenger tire which some exhaust does leak out of. The other day my O2 sensor triggered my check engine light. Wondering if I should just replace the whole exhaust system - my muffler is fine its just the rest of the exhaust that is shot, or if I should just get an exhaust shop to fix the rusted parts. I dont want to put a fancy exhaust or a soup can on the back of my car, I am perfectly fine with a stock or close to stock exhaust, I just want it to be in good shape since the car is pretty low KMs and will last me for a long time. Any advice would be greatly appreciated!
 

·
Administrator
Joined
·
6,864 Posts
Sounds like you just need a B-pipe. I would check with your local exhaust shop on their recommendations as far as repair or replace that section. Unsure what all is available as far as parts options in your region.

As far as the 02 sensor, depends on which one gave you a CEL as far as what action is needed. Not related to the leak.
 

·
Registered
Joined
·
29 Posts
Discussion Starter · #3 ·
Yeah I was thinking an exhaust shop could just replace the rusted out parts, and as for the O2 sensor it was sensor 1 bank 1 CEL code P0133. The exhaust leak is just more of an annoyance since where it is split, is right at the heat shield. So it has pressed the heat shield into the bottom of the rear end which vibrates sometimes in 1st and 2nd gear just due to certain rpms and speed.
 

·
Administrator
Joined
·
6,864 Posts
Yeah I was thinking an exhaust shop could just replace the rusted out parts, and as for the O2 sensor it was sensor 1 bank 1 CEL code P0133. The exhaust leak is just more of an annoyance since where it is split, is right at the heat shield. So it has pressed the heat shield into the bottom of the rear end which vibrates sometimes in 1st and 2nd gear just due to certain rpms and speed.
Understood.


Purchase a Denso primary air fuel (o2) sensor and that should cure that problem unless you have deeper issues causing the CEL. Much cheaper than one from Honda...which is Denso anyway...
 
1 - 4 of 4 Posts
Top