Honda Prelude Forum banner

1 - 19 of 19 Posts

·
Registered
Joined
·
53 Posts
Discussion Starter #1
The other night my check engine came on again. I had the code read and found out it was a P0420 or "Catalyst System Efficiency Below Threshold (Bank 1)". I was wondering if anyone has an idea of what might be wrong. The car is running perfectly. The only thing I did to it recently was put some fuel injection cleaner in the gas tank. Do you guys think the cleaner might have messed with the emissions?
 

·
Bearderator
Joined
·
8,519 Posts
IBTK!

Well it's pretty straight forward, your catalyst efficiency is below threshold. Means your catalytic converter is not working as well as it should be. Time for a replacement.

Hint: Magnaflow makes both OE-Spec and High Flowing direct fit replacements for much less than the dealership will charge for a new one.
 

·
Registered
Joined
·
53 Posts
Discussion Starter #3
IBTK!

Well it's pretty straight forward, your catalyst efficiency is below threshold. Means your catalytic converter is not working as well as it should be. Time for a replacement.

Hint: Magnaflow makes both OE-Spec and High Flowing direct fit replacements for much less than the dealership will charge for a new one.
My mechanic said it might not be the converter itself though. I hope its not, because i am kind of low on money. I guess if worse comes to worse i can still drive it like this.
 

·
Registered
Joined
·
677 Posts
yep, your cat is on its way out or you have a header leak, which was my p0420 nightmare. you can drive it like that, but for 125 bones, you could have an almost new random technology high flow cat, click the link in my sig for pics...not to whore my thread out or anything...;)
 

·
Registered
Joined
·
5,598 Posts
9 times out of 10, P0420 means bad cat. However it can also indicate a bad O2 sensor, but then it would be accompanied by a code for the O2 sensor.


Cure for bad cat = good dog.
 

·
Registered
Joined
·
53 Posts
Discussion Starter #7
9 times out of 10, P0420 means bad cat. However it can also indicate a bad O2 sensor, but then it would be accompanied by a code for the O2 sensor.


Cure for bad cat = good dog.
Are the preludes reliable cars? or did i make a mistake when I bought one?
 

·
Registered
Joined
·
284 Posts
My mechanic said it might not be the converter itself though. I hope its not, because i am kind of low on money. I guess if worse comes to worse i can still drive it like this.
i drove my cat with a bad cat till i had the money to fix it. worked out fine just polluted the air alot and the car felt that it didnt have the same power as it did with a good cat.

my prelude is very good as long as i take care of it.
 

·
Registered
Joined
·
5,598 Posts

·
Registered
Joined
·
637 Posts
If your cat is not all broken up and rattle then you can still save it. Just take it off and plug one end and pour chlorine bleach in there. Let it soak evernight then rinse off with garden hose, let it dry then put it back on and enjoy. Mine's P0420 free for 2 years already and passed CA emission everytime.
 

·
Bearderator
Joined
·
8,519 Posts
Are the preludes reliable cars? or did i make a mistake when I bought one?
See the mileage in my sig. That's the stock engine in there still, straight from the factory. This will be the second Honda I've driven to over 200,000 miles. The first is back on the road yet again driving fine with 240,000 miles.

Honda's from the 90's that aren't heavily modified by some teen when it was their first car = very reliable.
 

·
Bearderator
Joined
·
8,519 Posts
Like kronn said, it could be a bad o2 sensor (upstream).
......Kronn said 9 out of 10 times a P0420 means the catalytic converter is on it's way out, or is done. The other 1 out of 10 could be a bad downstream O2 sensor, as that's the one that measures the efficiency of the cat con.
 

·
Registered
Joined
·
53 Posts
Discussion Starter #14

·
Bearderator
Joined
·
8,519 Posts

·
Bearderator
Joined
·
8,519 Posts
Nope, that's OE replacement just like the autozone one you had selected.

I don't think they have a direct bolt on high flow, or at least I didn't see one on their website or ebay.
 

·
Registered
Joined
·
685 Posts
As some of you know I just recently installed a hytech rep headerf rom kronn and a brand new magnaflow high flow cat. I have never had any cel's before and I just got p0420 tonight. My cat is literally brand new and i have had it and the header on the car for over 2 weeks now; however, when the new cat was installed my old o2 sensor was reused. this is the SAME o2 sensor that came on the car when it was new. I am really hoping that my brand new magnaflow cat isnt already going bad immediately, and I am really hoping that this is the 1 out of 10 times that it is in fact an o2 sensor. any input would be appreciated please and thank you
 
1 - 19 of 19 Posts
Top