Honda Prelude Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hello all, first post here however have been cycling the forums a while and have helped me out alot but cant find an issue like this.
its a bit long winded but devil in the details right...
1988 2.0EX Carbed Automatic UK
bought 5 months ago after it had sat for 6 years. super clean however has its niggles.
Sorted most eg idle stall etc (still stalls when first started but hey)

Now however there are 2 issues probably related.
the car idles good when warm and can rev fine throughout the rev range, jack up the front of the car and one wheel spins when no throttle is applied im assuming this is fine due to open diff (right?) both spin when throttle is applied.
however when on the ground and driving it cannot get above 20 mph it feels like something is holding it back it revs and tries to go but cant.
i replaced all the pads and discs/rotors rebuilt all 4 callipers, drained and added new brake fluid and fully bled, fixed the handbrake so it comes on and off nicely.
checked the ECU and no codes
the front right feels harder to spin by hand in neutral then the rest but i thought maybe cause its FWD
i have removed and tested the fuel pump and it seems fine, i checked spark plugs they look fine too but have ordered new just to be sure
ALSO...
the light for low brake fluid/handbrake is on, the switch moves fine the handbrake unclamps, fluid is full and bled.
i jumped the cables and it stayed on.
but despite all the brake work they are still very spongey, they build pressure when the car is off which keeps leading me to air in the system but ive bled them multiple times and it doesn't seem to have any, i have looked for leaks and also cant find

any help will be appreciated, thanks to you all
 

·
Registered
1999 base, 5spd B91M
Joined
·
11 Posts
Im curious why you were so certain the brakes needed to be changed. But jumping right to it, with the engine running does the pedal sink to the ground? With the engine off, does the pedal sink to the ground? If not, can you repeatedly pump it 5-10 times to get it hard to the point where it doesnt move?
For what its worth, drive it around for a block or so and spash water onto each rotor.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
It had been sitting a while and the brakes were shot on needee replaced (pads/discs) while off decided might as well strip and clean up the callipers too.
Engine off - pedal builds pressure and feels fine
Engine on - pedal sinks and wont build pressure
 

·
Registered
1999 base, 5spd B91M
Joined
·
11 Posts
I dont really have any good news for you bro. Having a car that old is going to be a money pit. You can try and save it or u can stop here and save yourself the headaches. I would have a hard time helping you and being okay with it because this is not a situation u want to be dealing with. check your vacuum hoses, check the brake pedal to firewall for fluids. theres probably an internal leak at the booster. but then u have the 20mph thing
 
1 - 6 of 6 Posts
Top