Honda Prelude Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I have a 1998 Prelude H22a4 fully stock, only mods are catback exhaust (3inch all way back), open headers and air intake. A month ago the CEL came on and said its running rich and was throwing a fuel pressure regulator code, so I replaced it with an OEM and the code went away. Now it's misfiring at idle and when shifting gears, it also misfires when holding an rpm. I don't drive the car hard and i sometimes do engage VTEC but not all the time.
I've replaced spark plugs, plug wires as well as the air filter but it's still misfiring.
CEL is on and codes says its running lean, ive checked to make sure no leaks are present and 02 Sensor is working; so is the MAF sensor so im not sure what else to check for..

Any tips on figuring out whats wrong would be very much appreciated !:D
 

·
Registered
Joined
·
67 Posts
air intake leak past maf????....its manual right?......misfires under no load...fuel???...if you floor it..under load ..doesit misfire? (max fuel) im thinking fuel problem
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
air intake leak past maf????....its manual right?......misfires under no load...fuel???...if you floor it..under load ..doesit misfire? (max fuel) im thinking fuel problem
Yes it is manual and now it is misfiring under no load and when shifting gears but does not misfire whenever i shift around 4500 rpm. it does not misfire when flooring it underload as long as i shift over 4500. I am also thinking fuel is the issue but not sure where to look first, and the funny thing is that whenever i am going uphill it wont misfire, and when its downhill or flat it does misfire under load. Also when i come to a red light or a complete stop the rpms drop to 0 and then the engine catches itself from stalling.
 
1 - 3 of 3 Posts
Top