Honda Prelude Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
118 Posts
Discussion Starter · #1 ·
Okay so about a week before the holidays, my 90 prelude wouldnt start on me, it was hesitating, hesitating, hesitating, after about 3 or 4 tries to get her to start, BAM! starts turning over abnormally fast, close to 2 times as fast. im thinking wow okay either no more compression or hopefully an issue with the fuel pump... so i left it in my driveway until i had time to tow it into my brothers shop (i had another car to drive). now yesterday im towing it out of my driveway by ghetto means so i can get it on the road and use my roadside assistance plan (LOL!) and once its on the road, my buddy goes.. what happens when you try to start it? so i show him (bad idea i know).. and a couple slow turns, as the battery was nearly drained, and BOOM fires up no problem... now should i take it to the shop either way? or trickle charge the battery and see what happens... if i should be taking it to garage id like to drive it rather than tow it...

If you actually read that, i highly appreciate it and thanks in advance to people that reply.
 

·
Registered
Joined
·
2,423 Posts
Charge up the battery and drive it around for a while. Get the engine up to temp. You might just be cleaning out some junk build up.

Sounds like the PGM-Fi relay to me. Have you ever had that replaced?

How long has the car sat?
 

·
Registered
Joined
·
567 Posts
Well I'll tell you it didn't do that for nothing. Seeing that it started with such a fury sounds like the fuel pump was working fine and your lucky you didn't flood the engine. Check your spark plugs and all your ignition wiring first. Rent a compression tester, although I don't really think that could be the culprit, so maybe don't lol. Take your alternator to AutoZone and they'll test it for free. Also take the battery too. All these are cheap-free solutions, minus parts that you find out are bad. It's better than PAYING someone to find the issue and then paying for parts.
 

·
Banned
Joined
·
13,157 Posts
sounds to me like a bad main relay. aka the pgmfi relay as mentioned above.
when you say it started turning over twice as fast, it was actually probably trying to start but not quite fully firing.

i'd simply do a full tuneup on it, and then replace the main relay just because, and see how it works after that.
cuz even if the main relay is ok, it wont be for much longer lol, they always go at some point around this age, so by replacing it now you wont have to worry about it in the future and eliminate the possibility of getting stranded somewhere.
and just so you know, the main relay powers the fuel pump, the fuel injectors, and a few 12v sensors

and when i say do a full tuneup, i am implying to also do a valve lash adjustment and adjust the idle and ignition timing properly as per the writeup i made a while back
 

·
Registered
Joined
·
2,423 Posts

·
Registered
Joined
·
118 Posts
Discussion Starter · #6 ·
thanks guys, turned out it was a ground, but now engine light came on and 2 sensors on the distributor are going..... problem after problem
 
1 - 6 of 6 Posts
Top