Honda Prelude Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
49 Posts
Discussion Starter #1
Hey guys. My car's speedometer just does not work. I have had a few people check it out and tell me it's a sensor, or a solenoid r a fuse... etc.
The thing is that every now and then, when it's hot weather ive noticed mostly, the speedo will jump up and down and just bounce and then go back down and stay there. The odometer works great, all the lights are functioning properly, but no speedo.

It's the last thing left to fix on my car, then Im setting up my music system. So, can anyone shed some light, or a diagram/picture of our wiring or engine that shows where i should be looking.

Also, is this dangerous, will the car's rpms be messed up eventually by it, or are other functions such as the abs, 4ws, and tranny not working as good as they could cuz they have no clue how fast Im going?

Please give me a shout.
Thank you
Steve
 

·
The Good Stuff
Joined
·
3,587 Posts
I had the problem with my Accord... The speedo would just go haywire going up and down then it'd settle on 0. I think it was just a sensor that I had to replace. Take it to Autozone and get a free diagnostic test and see if that shows up anything.
 

·
Registered
Joined
·
49 Posts
Discussion Starter #4
see, thats the disparity, some think one thing, others believe something else. I dont believe Autozone offers free diagnostics here, Im in Miami, nothings free but I will call. Thanks so far.

As far as my other concerns Im not gonna die in a fiery wreck that worst of all will be my fault, Right?
 

·
Registered
Joined
·
1,109 Posts
When your speedo jumps, does it to it when you're stopped too, or just when ur moving? If it's only when ur moving it's your gauge, but if it's doing while you're stopped as well, then it's your speed sensor.
 

·
Registered
Joined
·
49 Posts
Discussion Starter #6
does it when im stopped too. most of all when im stopped
Ok so its a sensor, how many do we have and where can i find one to buy?
I see sensors online and at autozone, but i dont know what one fits in our cars.

Thanks
steve
 

·
Registered
Joined
·
149 Posts
my vss went bad several months back. it's located on the top of the tranny, kind of in the back.

to take it off you will need to temporarily undo the shift linkage. take it off, spin the little shaft on the vss, and use a voltometer to read the current coming out of the two wires on the sensor. if the voltometer reads nothing, replace the sensor.

(it works by spinning a small shaft on the sensor, which sends a small current through the wires. the ecu reads the strength of the current, telling you how fast you are going.)

this will cost about 140 bucks for the new sensor. if the sensor is good, i have no idea what the problem is.

good luck man..
 

·
Registered
Joined
·
1,109 Posts
Just go up to someone at Autozone and tell them you need a speed sensor for your Prelude. They'll be able to get you one right then or order it. Their computers tell them exactly which sensor it is so there won't be any guessing involved.
 

·
The Good Stuff
Joined
·
3,587 Posts
DarkFury said:
Just go up to someone at Autozone and tell them you need a speed sensor for your Prelude. They'll be able to get you one right then or order it. Their computers tell them exactly which sensor it is so there won't be any guessing involved.
We obviously don't go to the same Auto Zone. The computer at the one I go to really only gets in the ballpark. It rarely gives anything specific. I think I'm going to get a diagnostic tester for myself when I get a little spare cash.
 
1 - 10 of 10 Posts
Top