Honda Prelude Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
49 Posts
Discussion Starter · #1 ·
So 1st I broke the alternator bolt when hitting 3rd. Then I broke both oem belts with hitting 3rd. Tonight I broke the front engine mount when hitting 3rd. I looked on hondapartsnow but the diagram doesn't really show the front engine mount. Anyone recommend an oem Honda original equipment front engine mount?
 

·
Registered
3 gen
Joined
·
92 Posts
So 1st I broke the alternator bolt when hitting 3rd. Then I broke both oem belts with hitting 3rd. Tonight I broke the front engine mount when hitting 3rd. I looked on hondapartsnow but the diagram doesn't really show the front engine mount. Anyone recommend an oem Honda original equipment front engine mount?
Got it used oem mount. Contacto. 19392843318
 

·
Registered
Joined
·
419 Posts
OEM mounts aren't any better than modern aftermarket mounts. At least for this application. And if the front mount is breaking when you are hitting third gear, there is probably a lot more movement from the other mounts as well. Check the rear mount specifically.
 

·
Registered
Joined
·
49 Posts
Discussion Starter · #7 ·
OEM mounts aren't any better than modern aftermarket mounts. At least for this application. And if the front mount is breaking when you are hitting third gear, there is probably a lot more movement from the other mounts as well. Check the rear mount specifically.
Is it easy to remove or find? I Have not even tried looking for it.

I did get a coolant leak right under the throttle body to the front side. The hose was oem and dry rotted. By luck I had a huge roll of that same size hose. So I took the clamps off both ends and fixed it.
 
1 - 8 of 8 Posts
Top