Honda Prelude Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
281 Posts
Discussion Starter · #1 ·
Evening all,

Working through a rich fuel condition. P0172 and P0175 codes. Working thru the Helms starts with fuel pressure. I have 54psi with vacuum disconnected and pinched from the regulator and 44psi with it connected. Car is completely stock. Following the Helms again for Hi psi pressure says to check the regulator. The regulator passes according to the helms by the psi going up and down when add and subtract the vacuum line to the regulator. By the way, my fuel trims are ST FTRM1 -27.3 and LT FTRM1 -17.2. Assuming the regulator is good(no fuel present at the regulator, all dry) I moved on to checking the fuel return tube (Helms again). Ran a hose from the regulator return line to a bucket. The psi is still hi at 54 and 44. Also, I have tried two different fuel pressure testers. I am sort of stumped here. Why I have a hi fuel pressure and the helms says my regulator is good.

For the heck of it I moved onto the HO2 sensor. Got the car hot and into closed loop. At 3K rpm the voltage from O2S11 was below and above .3 and .6. Going from .08 to .85. The sensor is good. The next step would be the EVAP purge solenoid, but I need to get a vacuum pump to check it.

I am looking for input on the high fuel pressuer though at this point in my troubleshooting.

Thanks guys

Sid
 

·
Registered
Joined
·
2,344 Posts
Is there any chance that someone put in the wrong fuel pump? Or an aftermarket fuel pump?
 
1 - 2 of 2 Posts
Top