Honda Prelude Forum banner
overheating
1-10 of 10 Results
  1. 5th Gen
    My engine, while accelerating, will get to about 213°F and then cool back to normal after I reach 15mph. While the temperature is rising, my RPMs and my speedometer jump around. Thoughts?
  2. 5th Gen
    Good morning, I got a 97 Prelude that I have had for about 7 years, running well but come up with some issues lately most annoying being overheating almost daily. Mechanic told me that one of the fans in the stock radiator isnt functioning right. Got it fixed once and its overheating constantly...
  3. 3rd Gen
    I bought the car 2 months ago, 3rd gen 2.0s b20a3 carbureted. I did search for how to fix this, wasnt included in the write ups or general search. When i bought the car it overheated constantly, no thermostat, thermostat gasket, bad worn hoses, wrong coolant, and a clogged up radiator. 3rd week...
  4. 4th Gen
    So I have a 1992 prelude, with a F22B1. And the gauge reads that its overheating. I took it to a mechanic, they said it was the head gasket, but the engine shows no signs that it is the head gasket. There is no water in the oil, the engine does not lose power, the engine does not rattle or...
  5. 3rd Gen
    Some pals and I are racing a gen3 Prelude in LeMons. The car is an '88 Si and performs well, though with nearly 270,000 miles we've had to replace various things. Last winter we rebuilt the engine, boring the B20 out to 83mm to take B21 pistons (aftermarket from RockAuto) and doing some minor...
  6. 5th Gen
    Hey Guys! I Did a little looking around the forums and such, but I need a fresh opinion, especially one that fits my particular situation: AUTOMATIC H22A4 6 months ago, AAA informed me my radiator was cracked, still functional, but leaking. A month ago (after buying an 80 dollar radiator but...
  7. 4th Gen
    So I just finished swapping the timing belt on my 95 SI and I thought everything sounded great. After taking it for a test spin to the store, however, it seems that my engine is super overheating! Not sure what could cause this...didn't have any such problems before so... Could this be a result...
  8. 4th Gen
    on my last thread I talked about my o2 sensor problems and how my car was fouling one every 3 months. well after some ideas and possibilities was talked about, I decided to check my egr ports. I took a look at my egr valve and noticed that it was broke completely in half at the base. I took it...
  9. 3rd Gen
    hey guys so a while ago i had a thread concerning my lude overheating on the highway. not sure why it was, but since i've only done city driving since, i havnt noticed the lude getting hot so i forgot about it. anyway, it snowed tonight, which for me equals drifting :D aww yeaa. anyway, i wasnt...
  10. 5th Gen
    Ok, so recently I have been having a overheating issue. I removed the im butterfly spacer and filled the two ports on the im with Honda bond and jb weld. I have blown the hose that goes to the air control valve, picture #7 due to no hose clamps, but yesterday the #8 hose split. I don't know if...
1-10 of 10 Results
Top