Honda Prelude Forum banner

odometer

  1. odometer reading wrong

    5th Gen
    Hey guys, I've been looking and haven't found anything regarding this, but I've been noticing that my odometer seems to be marking wrong. At first i thought I was just being paranoid, but after a couple runs I've noticed that my odometer and trip meter aren't adding up. On my last...
  2. What to do about AT cluster after swap?

    4th Gen
    Hey guys, My 93 4ws is undergoing a 5speed swap and I'm trying to decide what to do about my AT gauges. I have a 96 MT parts car for the swap and it has the EL gauge too, but also has 80,000 on odometer compared to my current 120,000 on the 93. (I don't want to swap engines yet, cuz I went...
  3. Speedometer messed up again! HELP!!! ]=

    2nd Gen
    So I just bought my '87 2.0 Si 'lude USDM back in Feb. with an already non working speedometer (it'll be stuck at 0 mp/h), but everything else works fine on the cluster. My dad and I last week went to the junkyard and picked up a cluster from an '87 also and it worked, the speedometer was...
  4. Speedometer jumping

    3rd Gen
    Cant find online what is my odometer Problem ..im not sure if Wire or vss or something Or maybe i put wrong keyword o google Here is the video i take.. B20a5 automatic
  5. Speedometer and Odometer not working

    3rd Gen
    Ok, so I did some searching first but the information is spotty at best. I have a 90 SI 4WS and I've been getting an intermittant check enigine light for the last few weeks, but I haven't had time to check it out (plus the weather has been pretty crappy.) So... the other day, I hop in my car...
Top