Honda Prelude Forum banner
egr
1-7 of 7 Results
  1. 5th Gen
    my car is a 98 Prelude Base model with 4th gen h22a swap. always had an egr cel since the swap and ive replaced everything under the sun related to the egr sustem and still getting the code. not really trying to remove the manifold to clean out the ports cause I've heard it doesnt always cure...
  2. 5th Gen
    Just did a full clean of my EGR ports and was wondering if any of you guys have know a way of keeping them clean. I don't really feel like doing it ever again so was curious what you guys do. Seafoam every now and then perhaps?
  3. 4th Gen
    I was planning on cleaning my EGR ports using the method discused with the slide hammer. I thought there were supposed to be brass plugs over the ports but apparently there arent :confused: . so why is my lude different and are there any other methods i could use to get rid of the EGR related CEL?
  4. 5th Gen
    Hey all, As I prefix all my posts (read: pleas for help), I am very new to working on my car and need quite a bit of explanation to get me along. Anyway here's the newest symptom to diagnose: When the car is warm and put under load it will occasionally stutter really badly. It happens...
  5. 3rd Gen
    my cel came on saying my egr was bad, went to the shop got it fixed, passed emmisions, and the cel is still on, reset my ecu... still ON... it still throws a code 12 = EGR. WTF do i do??? PLZ HELP ITS SO ANNOYING!!!!! thanks...lol
  6. 5th Gen
    I'm new on here peeps,Was curious if anyone could help me out. I recently bought a 98 base with megan header,teat pipe and exhaust. Has a full tune-up including aem fuel filter.MSD cap,rotor,and wires,NGK plugs. The prob is when i am taking off after warm up the car kind struggles like there is...
  7. 5th Gen
    .
1-7 of 7 Results
Top